Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > Engine Management
p06 ecu converted to vtec problems....help please >

p06 ecu converted to vtec problems....help please

Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

p06 ecu converted to vtec problems....help please

Old 04-05-2005, 08:42 PM
  #1  
0.0 BAR
Thread Starter
 
Join Date: Mar 2004
Posts: 49
Default p06 ecu converted to vtec problems....help please

I have a p06 converted to vtec that I bought from someone on HT awhile back. The engine is a JDM d15b vtec with a 4 wire o2 from my old d15b7.

I went through the troubleshooting on PGMFi and if I burn a chip with a stock p06 bin from this website it doesnt get a CEL. I have tried the p28 bins and they all give a CEL code 21. The troubleshooting guide says its the program if the stock non vtec program works but the vtec bin I am using is a stock program from here http://www.pgmfi.org/twiki/bin/view/...efinitionCodes
It is the p28-a01 I am using.

I have checked the vtec solenoid and pressure switch and they are fine. I used the FSM procedure and I also tested the solenoid by jumping it and verifying the click. The wiring tests fine all the way to the ecu plug. Any ideas?

Thanks,
Aaron
freakaccident is offline  
Old 04-05-2005, 09:07 PM
  #2  
0.0 BAR
 
Join Date: Mar 2004
Posts: 0
Default Re: p06 ecu converted to vtec problems....help please

Maybe who ever converted it did it wrong.
SpankedYA! is offline  
Old 04-05-2005, 09:27 PM
  #3  
0.0 BAR
Thread Starter
 
Join Date: Mar 2004
Posts: 49
Default Re: p06 ecu converted to vtec problems....help please

I checked and all of the proper components appear to be present. I may end up replacing them myself but I'm hoping it is something more simple.
freakaccident is offline  
Old 04-05-2005, 09:27 PM
  #4  
3.0 BAR
 
Join Date: Apr 2003
Posts: 11,059
Default Re: p06 ecu converted to vtec problems....help please

Originally Posted by CSaddict
Maybe who ever converted it did it wrong.
that's what it sound like to me. can you get a close up picture of the upper left hand corner of the ecu (on the plug side)?
projekteg is offline  
Old 04-05-2005, 09:33 PM
  #5  
0.0 BAR
 
Join Date: Mar 2004
Posts: 0
Default Re: p06 ecu converted to vtec problems....help please

Have you tried a different version of Uberdata?
SpankedYA! is offline  
Old 04-05-2005, 09:42 PM
  #6  
0.0 BAR
Thread Starter
 
Join Date: Mar 2004
Posts: 49
Default Re: p06 ecu converted to vtec problems....help please

I will have a pic in a few minutes.

Uberdata isnt a possibility. I used a stock bin from pgmfi. Untouched.
freakaccident is offline  
Old 04-05-2005, 09:43 PM
  #7  
3.0 BAR
 
Join Date: Apr 2003
Posts: 11,059
Default Re: p06 ecu converted to vtec problems....help please

Originally Posted by CSaddict
Have you tried a different version of Uberdata?
he's burning stock .bin's without opening them in any program and he said the p06 didn't give a cel, so it has to be that it was converted wrong.
projekteg is offline  
Old 04-05-2005, 09:46 PM
  #8  
0.0 BAR
Thread Starter
 
Join Date: Mar 2004
Posts: 49
Default Re: p06 ecu converted to vtec problems....help please

Pic

freakaccident is offline  
Old 04-05-2005, 09:49 PM
  #9  
0.0 BAR
Thread Starter
 
Join Date: Mar 2004
Posts: 49
Default Re: p06 ecu converted to vtec problems....help please

If you see anything wrong with this pic please let me know. It is a 02d011f0 board.
freakaccident is offline  
Old 04-05-2005, 10:05 PM
  #10  
1.5 BAR
 
Join Date: Dec 2002
Posts: 1,008
Default Re: p06 ecu converted to vtec problems....help please

ck the diode (d11 i think) and the stripe should correspond w/ whats on the board. the tantalum cap should have a + on it that corresponds with the board also...make sure thats installed correctly too. i can't tell if j10 is jumped.

here are the parts you need:

C60 - 1uF, 35v electrolytic (tantalum?) capacitor
J10 - 0 Ohm jumper wire
Q101 - A143 PNP switching transistor
R201 - 10K resistor (Brown-Black-Orange-Gold)
IC14 - 515 XHigh Side Switch
D11 - Clamping Diode

the parts differ from the 17 series board and are fewer, but commonly get confused between the 2. the switching transistor and highside switch get changed from c2785 transistor and 505 highside switch sometimes are found in the other board and get used in the 11 board and not work. jumper must be used if using only 1 515 highside switch.
scttydb411 is offline  

Thread Tools
Search this Thread
Quick Reply: p06 ecu converted to vtec problems....help please


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.