Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

^^^Are My Injectors Bad?

Old 06-01-2006, 10:48 PM
  #1  
1.0 BAR
Thread Starter
 
Join Date: Oct 2005
Posts: 297
Default ^^^Are My Injectors Bad?

Alright. I ran an FMU for a little while but a kinked vaccuum line led to a few broken ringlands.

anyways. i've been trying to get my SAFC II, 460cc injectors, and 2 bar MAP to work for a few weeks. With the stock injectors and fmu and stock map sensor the car runs great. With the SAFC II, 2 bar MAP and the 460cc's the car runs aweful. Undriveable. I know for a fact the SAFC is installed correctly. also the 2 bar. And both the products are brand new. Anyways the car idles like it has a bad o2 sensor when I input a negative correction on the SAFC. Im gettin about a 13.0 a/f ratio with 0 correction. This is pretty rich, but when i step on it a little in neutral, the car almost dies.

So i know the map sensor and the safc are installed perfect. and when i have the stock injectors in the fuel corrections work, but with the 460's, 2 bar map, the corrections seem to almost yeild no effect.

The only thing else left to be the problem seems to be the INjectors. im going to have them flow tested asap, but wanna know what u guys think. Sound like bad injectors to you?

Thanks.
penguininatux is offline  
Old 06-01-2006, 11:18 PM
  #2  
0.0 BAR
 
Join Date: Dec 2002
Posts: 0
Default Re: ^^^Are My Injectors Bad?

<<<<<<<<<<<<<<<<<>>>>>>>>>>>>>>
Guy-Fast is offline  
Old 06-02-2006, 12:37 AM
  #3  
1.0 BAR
Thread Starter
 
Join Date: Oct 2005
Posts: 297
Default Re: ^^^Are My Injectors Bad?

what does that mean?
penguininatux is offline  
Old 06-03-2006, 12:18 PM
  #4  
1.5 BAR
 
Join Date: Jun 2003
Posts: 1,145
Default Re: ^^^Are My Injectors Bad?

why not use the stock map sensor?
civicvtecb16a is offline  
Old 06-03-2006, 04:04 PM
  #5  
1.0 BAR
Thread Starter
 
Join Date: Oct 2005
Posts: 297
Default Re: ^^^Are My Injectors Bad?

doesnt work. runs like 12 a/f at -%50. and same symptoms as the 2 bar. idles sparatically, and feels like the timing is off by like 30 degrees under acceleration. i know it would be advanced a lot, but i still get the same problem at 0 correction with the 2 bar. so i think it's gotta be the injectors. but on the other hand i cant see how injectors could go bad?
penguininatux is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
widebody93
General Discussion
85
09-10-2008 08:23 AM
SpankedYA!
Fabrication
29
08-18-2008 06:58 PM
Boosted_StinkyNuts
Engine Management
3
04-08-2008 03:39 PM
Civic4Sale
Hybrid/Tech
1
09-02-2005 03:17 PM
Kaneda13
General Discussion
25
04-08-2003 01:08 AM


Thread Tools
Search this Thread
Quick Reply: ^^^Are My Injectors Bad?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.