Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > Engine Management
started it up and there was shit loads of smoke! >

started it up and there was ---- loads of smoke!

Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

started it up and there was ---- loads of smoke!

Old 08-04-2003, 03:11 AM
  #1  
1.0 BAR
Thread Starter
 
Join Date: Dec 2002
Posts: 381
Default started it up and there was ---- loads of smoke!

anyone got any tips for making my engine less smokey? It is a 1.6 CRX with turbo conversion, on idle it is poring out white, greyish smoke. Fuel PSI is at about 45PSI and 390cc injectors are in being controlled by SAFC set to about -30% its smells to rich thou and cuts out on idle if i set the SAFC any lower. Any of you guys got smokey engines when you started up your turboed car? It only seems to have happened since i put the injectors in also
thanks
djnikko is offline  
Old 08-04-2003, 05:17 PM
  #2  
3.0 BAR
 
Join Date: Mar 2003
Posts: 5,285
Default Re:started it up and there was ---- loads of smoke!

Well white smoke means your burning coolant or water. But if it's black, thats your engine running rich.
tranceminister is offline  
Old 08-04-2003, 07:45 PM
  #3  
1.5 BAR
 
Join Date: Dec 2002
Posts: 1,002
Default Re:started it up and there was ---- loads of smoke!

did it smoke before the turbo?

if it didnt then either your oil pressure is too high or your turbo oil seals are blown.

oil smoke is bluish white, white smoke is coolant burning, usually from a blown headgasket.
ZexRex is offline  
Old 08-05-2003, 09:32 AM
  #4  
0.5 BAR
 
Join Date: Jan 2003
Posts: 152
Default Re:started it up and there was ---- loads of smoke!

i ran into the same problem with a intake manifold gasket that was leaking. If it didnt smoke before than there is no reason that it should be a problem with the motor. is the turbo water cooled?
stevecivic is offline  
Old 08-05-2003, 11:20 AM
  #5  
3.0 BAR
 
Join Date: Apr 2003
Posts: 2,580
Default Re:started it up and there was ---- loads of smoke!

It could be a clogged or kinked oil drain, that made mine smoke like hell
fork is offline  
Old 08-05-2003, 12:30 PM
  #6  
3.0 BAR
 
Join Date: Feb 2003
Posts: 9,089
Default Re:started it up and there was ---- loads of smoke!

this guy had the same problem.. read on..

https://www.homemadeturbo.com/forum/...;threadid=5613
88crxSi is offline  
Old 08-12-2003, 08:04 AM
  #7  
1.0 BAR
Thread Starter
 
Join Date: Dec 2002
Posts: 381
Default Re:started it up and there was ---- loads of smoke!

i will tighten up the inlet manifold tonight i have a strange feeling that could be it you know. Do turbos smoke when u first install them anyway? The smoke wasnt as bad the other day. but still have oil in my actuator pipe!>!?!?! Mmmm
djnikko is offline  
Old 08-12-2003, 09:14 AM
  #8  
3.0 BAR
 
Join Date: Feb 2003
Posts: 9,089
Default Re:started it up and there was ---- loads of smoke!

what are the dimensions of the oil feed/drain.
88crxSi is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
samson
General Discussion
20
01-19-2007 03:35 PM
wikidsi
Turbo Parts For Sale
10
11-24-2006 09:03 PM
crxfreak88
Forced Induction
11
01-10-2004 12:40 PM
tigersball
Turbo Parts For Sale
12
10-15-2003 11:45 PM
Turboteggy
Forced Induction
1
05-04-2003 01:24 AM


Thread Tools
Search this Thread
Quick Reply: started it up and there was ---- loads of smoke!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.