Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > Engine Management
Ran in to a problem with the LC1 and O meter setup. >

Ran in to a problem with the LC1 and O meter setup.

Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

Ran in to a problem with the LC1 and O meter setup.

Old 06-11-2007, 11:07 PM
  #1  
!! UNCONFIRMED EMAIL !!
Thread Starter
 
Join Date: Dec 2002
Posts: 2,949
Default Ran in to a problem with the LC1 and O meter setup.

I finally wired everything up and the LC1 did its calibration for the first time. The status light is solid so I know the LC1 works. I hooked up the Ometer as per directions, Ground, Positive and Analog2 0-5v (brown) from the LC1.

The problem is when I turn on the car the O meter just counts down from 18:1 to 11:1 and stays there. I get no AFR reading. I can get on the gas and its still sitting at 11:1. what could be causing this problem? I would really like some help here.
Xgenturbo is offline  
Old 06-12-2007, 09:16 AM
  #2  
1.0 BAR
 
Join Date: Sep 2006
Posts: 326
Default Re: Ran in to a problem with the LC1 and O meter setup.

Have you looked at the output of the LC-1 in logworks... Need to determine if the calibration is off or if it's another issue.
The LC-1 can be setup for different output ranges.
dcg9381 is offline  
Old 06-12-2007, 12:00 PM
  #3  
!! UNCONFIRMED EMAIL !!
Thread Starter
 
Join Date: Dec 2002
Posts: 2,949
Default Re: Ran in to a problem with the LC1 and O meter setup.

Originally Posted by dcg9381
Have you looked at the output of the LC-1 in logworks... Need to determine if the calibration is off or if it's another issue.
The LC-1 can be setup for different output ranges.
To be honest with you I havent even hooked it up to Logworks yet. Going to today or tomorrow hopefully. I thought that it should give me some readings if I just plug and play. But I'll check it out.
Xgenturbo is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ichbinsobose
Wanted
1
11-06-2007 11:27 PM
Heath
Engine Management
4
04-25-2007 10:17 PM
jarebear667
Turbo Parts For Sale
13
10-06-2006 07:55 PM
sohcpwr
Hybrid/Tech
4
07-28-2006 09:18 PM
96_civ
Forced Induction
2
07-04-2005 06:48 PM


Thread Tools
Search this Thread
Quick Reply: Ran in to a problem with the LC1 and O meter setup.


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.