Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

Issues with o2 sensor pre-turbo?

Old 04-13-2005, 12:48 AM
  #1  
3.0 BAR
Thread Starter
 
Join Date: Apr 2004
Posts: 9,802
Default Issues with o2 sensor pre-turbo?

need to toss my o2 into the HF mani spot for the time being, any issues with this at all since its pre-turbo? i can disable it completely, tho the car runs like total *** in open loop, guess that means its just time to tune right?
FooK is offline  
Old 04-13-2005, 07:13 AM
  #2  
0.0 BAR
 
Join Date: Mar 2004
Posts: 0
Default Re: Issues with o2 sensor pre-turbo?

The innovate website says an O2 will not work properly before a turbo due to excessive pressure. Wether it will work or not, I'm sure it will work for emissions.
SpankedYA! is offline  
Old 04-13-2005, 08:04 AM
  #3  
1.5 BAR
 
Join Date: Aug 2004
Posts: 949
Default Re: Issues with o2 sensor pre-turbo?

I have my NBO2 in the HF spot and a WBO2 bung on the downpipe before the cat. Both work fine.
95RedEX is offline  
Old 04-13-2005, 08:26 AM
  #4  
3.0 BAR
Thread Starter
 
Join Date: Apr 2004
Posts: 9,802
Default Re: Issues with o2 sensor pre-turbo?

Originally Posted by 95RedEX
I have my NBO2 in the HF spot and a WBO2 bung on the downpipe before the cat. Both work fine.
cool thats what im going to do.
FooK is offline  
Old 04-13-2005, 04:10 PM
  #5  
1.5 BAR
 
boosted_b16's Avatar
 
Join Date: Nov 2004
Posts: 820
Default Re: Issues with o2 sensor pre-turbo?

02 sensor in the stock hf mani. worked fine on my buddys car with the afc hack....
boosted_b16 is offline  
Old 04-13-2005, 04:47 PM
  #6  
1.0 BAR
 
Join Date: Apr 2003
Posts: 467
Default Re: Issues with o2 sensor pre-turbo?

I ran the stock o2 sensor in my hf manifold for a while. When i tried putting my wideband in the same spot though I had all kinds of random lean spikes in the data that weren't there after I put the wideband in the downpipe. I think you should be fine running the stock o2 there though. Personally though I just tuned my part throttle and run my car in open loop all the time now.
sohc_mshue is offline  
Old 04-13-2005, 04:57 PM
  #7  
1.0 BAR
 
Join Date: Sep 2004
Posts: 312
Default Re: Issues with o2 sensor pre-turbo?

yeah it'll be fine! i've ran mine that way for awhile. stock o2 in the hf manifold and when the wideband goes in it will be right after the turbo on the downpipe. i think with all wideband o2 sensors it is better to put it after the turbo on the dp for better readings
TiCaL is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Xgenturbo
General Discussion
16
07-05-2006 12:04 PM
4thgenhothatch
Forced Induction
7
02-19-2006 09:39 AM
Xgenturbo
General Discussion
13
05-15-2005 10:03 PM
G2turbo_terror
Forced Induction
6
04-03-2005 08:04 PM
MixKit
Forced Induction
2
02-16-2003 05:30 PM


Thread Tools
Search this Thread
Quick Reply: Issues with o2 sensor pre-turbo?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.