Hybrid/Tech B16 / B18 / ZC / D16 / H22 / Mini-Me Ask your Honda Engine Questions here.

need an electrician

Old 02-25-2009, 08:53 PM
  #1  
3.0 BAR
Thread Starter
 
Join Date: Mar 2008
Location: texas
Posts: 2,598
Default need an electrician

this is going to be a very complicated thing so just bear with me for a second.
i have an 86 rx7 n/a. right now the fuel pumpis not turning on. the the circuit opening relay is not working. because it is not getting a ground form the brown wire. i jumped it with a ground so that the pump would turn on but the car still does not start. it just floods the engine. now i tested the afm and it seems to be fine from what the shop manual says so now im stuck with a constant ground it floods with it just wired normally it does not even turn on. here is the wire diagrahm for what im talking about
http://www.cochran-racing.com/FSM/s4...NG_DIAGRAM.pdf
the relay im talking about is on page 30 its marked f-08 and the brown wire is not getting a signal what should i check next it is so close to starting and i just want to finally drive it
txdohczc is offline  
Old 02-25-2009, 09:14 PM
  #2  
0.0 BAR
 
Join Date: Apr 2008
Posts: 0
Default Re: need an electrician

Are you getting spark? If the AFM isn't working right it won't turn the fuel pump on. IE-if you unplug the MAF it will prime at key on, crank and run for 2 seconds before going closed loop and when it doesn't see the MAF it kills the fuel pump and dies. Does the pump prime at key on? Does it ever try to catch on its own? AFM's go out sometimes. The miata crowd uses those as an upgrade on older miata's and most carry a spare. I'd make sure the wiring to the sensor is correct and try swapping the MAF for a known good one.
bitchM0VE is offline  
Old 02-25-2009, 09:17 PM
  #3  
3.0 BAR
Thread Starter
 
Join Date: Mar 2008
Location: texas
Posts: 2,598
Default Re: need an electrician

Originally Posted by patsmx5
Are you getting spark? If the AFM isn't working right it won't turn the fuel pump on. IE-if you unplug the MAF it will prime at key on, crank and run for 2 seconds before going closed loop and when it doesn't see the MAF it kills the fuel pump and dies. Does the pump prime at key on? Does it ever try to catch on its own? AFM's go out sometimes. The miata crowd uses those as an upgrade on older miata's and most carry a spare. I'd make sure the wiring to the sensor is correct and try swapping the MAF for a known good one.
yeah its getting spark but the fuel pump is not priming with key on. the fuel pump turns on while cranking just not with in the on position. the brown wire going into the f-08 relay is not getting a signal but if i touch a ground to it it works perfect
txdohczc is offline  
Old 02-25-2009, 09:33 PM
  #4  
0.0 BAR
 
Join Date: Apr 2008
Posts: 0
Default Re: need an electrician

I'd say AFM is probably bad. Is the factory wiring in good condition? Are all your grounds hooked up properly and clean, tight battery connections, etc? Mazda's are picky about grounding. I looked at that wiring diagram a bit but man that ----'s hard to read. Got a better copy? On miataturbo.net I downloaded copies of the factory service manual w/ wiring diagrams. Much easier to read than that ---- you posted. I'm not familiar with that circuit you speak of, but it appears to be a cold start thing, like perhaps a solenoid/ injector that gives it a shot of fuel for sub-zero starting? If so grounding that would certainly flood the hell out of it.
bitchM0VE is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TLshizz
Engine Management
3
09-09-2003 02:25 PM


Thread Tools
Search this Thread
Quick Reply: need an electrician


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.