Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

wideband O2 sensor question (is it fucked?)

Old 07-01-2005, 12:34 AM
  #1  
1.0 BAR
Thread Starter
 
Join Date: Nov 2004
Posts: 319
Default wideband O2 sensor question (is it fucked?)

i have a Bosch wideband o2 sensor that came with my techedge WB and when i would plug it in it scrambles between 14-15 all the time in free air. It should display 20.00AFR after like 30 seconds of warming up right? and when i'm driving with the WB on the AFR meter can jump between 13-16 AFR so fast that i don't even know what the ------- AFR is. Even with narrow band O2 off it would jump around between those AFR very fast while at steady throttle. Is that normal or is my sensor fucked or i'm just too noob for a wideband haha .
topspeed is offline  
Old 07-01-2005, 01:09 AM
  #2  
0.5 BAR
 
Join Date: Nov 2004
Posts: 122
Default Re: wideband O2 sensor question (is it fucked?)

which wideband do you have I got a plx and i had to take my sensor out to put my regular 02 sensor in and if i cut the wideband on it will stay at 14.6 or so. this doesnt even have the o2 connected to it. also a/f can change fast like that and u be looking at it and watching it go from 14-10 -16 its just how much your a/f is changing.
Jimclure is offline  
Old 07-01-2005, 06:44 AM
  #3  
3.0 BAR
 
Join Date: Jul 2003
Posts: 6,449
Default Re: wideband O2 sensor question (is it fucked?)

If its changing so fast that you cant read it, chances are the sensor is done...my experience at least.
Chris Harris is offline  
Old 07-01-2005, 07:57 PM
  #4  
1.0 BAR
Thread Starter
 
Join Date: Nov 2004
Posts: 319
Default Re: wideband O2 sensor question (is it fucked?)

^ ----! wasn't hoping for that

anyone else have experience with this situation or can tell me that its normal?
topspeed is offline  
Old 07-01-2005, 07:58 PM
  #5  
1.0 BAR
Thread Starter
 
Join Date: Nov 2004
Posts: 319
Default Re: wideband O2 sensor question (is it fucked?)

Originally Posted by Jimclure
which wideband do you have I got a plx and i had to take my sensor out to put my regular 02 sensor in and if i cut the wideband on it will stay at 14.6 or so. this doesnt even have the o2 connected to it. also a/f can change fast like that and u be looking at it and watching it go from 14-10 -16 its just how much your a/f is changing.
Its a Techedge.
topspeed is offline  
Old 07-02-2005, 03:08 PM
  #6  
!! UNCONFIRMED EMAIL !!
 
Join Date: Dec 2002
Posts: 6,656
Default Re: wideband O2 sensor question (is it fucked?)

i was having doubts about weather mine was working proporly, so i bought a new one and it was reading like a full 1.0-1.5ar rich... if its a Bosch sensor just buy a new one if your in doubt, there like 40bucks from 1stvwparts.com
turbohf is offline  
Old 07-02-2005, 07:39 PM
  #7  
1.0 BAR
Thread Starter
 
Join Date: Nov 2004
Posts: 319
Default Re: wideband O2 sensor question (is it fucked?)

this sensor that i have is fairly new, barely any carbon stained on it and its a genuine Bosch O2 i don't really think it's the sensor but you never know right. I tested my WB and after like 10-15 seconds it read 45L so LEAN in free air haha thats a good sign.
topspeed is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Cray91
Turbo Parts For Sale
1
10-14-2008 01:52 AM
ekturbohatch
Hybrid/Tech
0
08-30-2007 10:13 AM
FooK
Turbo Parts For Sale
3
02-03-2006 12:15 AM
robs99si
Hybrid/Tech
1
10-31-2004 11:20 PM
civicunrest
Turbo Parts For Sale
0
05-14-2003 05:09 AM


Thread Tools
Search this Thread
Quick Reply: wideband O2 sensor question (is it fucked?)


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.