Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

Walbro 255 on Stock Motor Bad?

Old 04-09-2004, 12:31 AM
  #1  
0.0 BAR
Thread Starter
 
Join Date: Feb 2003
Posts: 0
Default Walbro 255 on Stock Motor Bad?

I'm trying to take care of as many little things I can before I call the troops over for the install day. I was wondering if I will have any negative side effects to installing my fuel pump before the turbo gets installed?
I'm under the impression that the new pump will be able to keep up with a higher flow, but will it effect the pressure? Thanks in advance.


MikeJ-2009 is offline  
Old 04-09-2004, 12:47 AM
  #2  
1.5 BAR
 
Join Date: Mar 2003
Posts: 1,190
Default Re:Walbro 255 on Stock Motor Bad?

I have been told that it does not affect the pressure. My friend installed a high volume in-tank fuel pump in his '01 Subaru Impreza before he installed his turbo kit, and had no negative effects.
willahlborn is offline  
Old 04-09-2004, 02:37 AM
  #3  
1.0 BAR
 
Join Date: Sep 2003
Posts: 297
Default Re:Walbro 255 on Stock Motor Bad?

We installed one on my cousins B20 civic and we have not had any problems. So i dont think it affects the pressure.
TMonarky is offline  
Old 04-09-2004, 07:09 AM
  #4  
3.0 BAR
 
Join Date: Mar 2003
Posts: 21,494
Default Re:Walbro 255 on Stock Motor Bad?

Nah, you'll be fine. You still have a FPR to stop it from building too much pressure. I ran a 255lph pump for a few years N/A with no problems.
__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
Dr.Boost is offline  
Old 04-09-2004, 11:30 AM
  #5  
1.5 BAR
 
Join Date: Jun 2003
Location: Plant city,fl
Posts: 1,136
Default Re:Walbro 255 on Stock Motor Bad?

The fuel pump should raise pressure.Mine went up 5 psi but doesnt affect the car at all.I think i actually got better mpg with it.
theebluecrx is offline  
Old 04-09-2004, 01:04 PM
  #6  
0.0 BAR
Thread Starter
 
Join Date: Feb 2003
Posts: 0
Default Re:Walbro 255 on Stock Motor Bad?

Ok, cool. Now I can get another thing done that we won't have to do at the install. Thanks guys.
MikeJ-2009 is offline  
Old 04-09-2004, 01:10 PM
  #7  
3.0 BAR
 
Join Date: Dec 2002
Posts: 12,569
Default Re:Walbro 255 on Stock Motor Bad?

yeah youll be kosher
hotrex is offline  
Old 04-13-2004, 01:15 PM
  #8  
1.5 BAR
 
Join Date: Apr 2003
Posts: 835
Default Re:Walbro 255 on Stock Motor Bad?

Might this be different if the High Pressure 255 is used?
bmaca455 is offline  
Old 04-13-2004, 03:09 PM
  #9  
0.0 BAR
 
Join Date: Jun 2003
Posts: 0
Default Re:Walbro 255 on Stock Motor Bad?

Originally Posted by bmaca455
Might this be different if the High Pressure 255 is used?
A 255lph pump is a 255lph pump, there's no high or low pressure Walbro 255.
Reddy is offline  
Old 04-13-2004, 03:33 PM
  #10  
1.5 BAR
 
Join Date: Apr 2003
Posts: 835
Default Re:Walbro 255 on Stock Motor Bad?

Originally Posted by Whitey
Originally Posted by bmaca455
Might this be different if the High Pressure 255 is used?
A 255lph pump is a 255lph pump, there's no high or low pressure Walbro 255.
http://www.autoperformanceengineerin...ml/fpapps.html has both options for sale. Preahaps they are just bastards trying to scheme you into spending a couple extra bills.
bmaca455 is offline  

Thread Tools
Search this Thread
Quick Reply: Walbro 255 on Stock Motor Bad?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.