Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

running way too rich help

Old 04-17-2004, 10:25 PM
  #1  
0.0 BAR
Thread Starter
 
Join Date: Apr 2004
Posts: 10
Default running way too rich help

Hey well firt off im running a 12.1 fmu and a 255 fuel pump with stock integra injectors. This is in a stock LS/vtec. I have a missing link and a fuel pressure reg. I unscrew the fuel reg all the way and at idal i get 60 psi of fuel which i think is quit a bit. I cant get it lower. So im woundering if its the 12.1 fmu thats doing it. Even when I drive it my air/fuel gauge shows rich. Its hard to drive it because its dumping so much fuel that it detonating. I have a td04 13c turbo off of a volvo if that helps. one other thing, when i received my missing link it didnt come with the fome air filter thingy so i stuffed cotton into it and im thinking that might cause the problem and now i get a check engine light. code 3.

well if any one has any ideas please let me know.

thanks
turboteg is offline  
Old 04-18-2004, 12:00 AM
  #2  
1.5 BAR
 
Join Date: Mar 2003
Posts: 1,190
Default Re:running way too rich help

first of all, narrowband a/f guages don't tell you much. basically that your a/f ratio is below 14:1, which is okay but doesn't tell you more than that (this is assuming your o2 sensor is still working properly). Second, I don't think you're "detonating", more likely bogging due to too much fuel or maybe going into limp mode. This may be related to the CEL 3 problem. Does the check engine light come one during boost, or just all the time?
willahlborn is offline  
Old 04-18-2004, 01:22 PM
  #3  
0.0 BAR
Thread Starter
 
Join Date: Apr 2004
Posts: 10
Default Re:running way too rich help

well the problem is i cant get any boost. most of the time my gauge is in the vac when im driving and my car revs up really slow. It bugs when i try to floor it.

does any one know if the stock volvo wastegate actuator is ajustable bucause i did turn it a couple times maybe i messed it up.
turboteg is offline  
Old 04-18-2004, 03:58 PM
  #4  
1.5 BAR
 
Join Date: Mar 2003
Posts: 1,190
Default Re:running way too rich help

it still sounds like you're dumping way too much fuel.
willahlborn is offline  
Old 04-18-2004, 11:13 PM
  #5  
0.5 BAR
 
Join Date: Apr 2004
Posts: 52
Default Re:running way too rich help

Is your FMU adjustable
turboindia is offline  
Old 04-19-2004, 01:25 AM
  #6  
0.0 BAR
Thread Starter
 
Join Date: Apr 2004
Posts: 10
Default Re:running way too rich help

no its not ajustable.
turboteg is offline  
Old 04-19-2004, 06:56 AM
  #7  
0.5 BAR
 
Join Date: Apr 2004
Posts: 52
Default Re:running way too rich help

I dont know about the Volvo, but if it is your FMU why dont you try with a lower ratio kit like 8:1It should clear your problem.
turboindia is offline  
Old 04-19-2004, 07:02 AM
  #8  
1.5 BAR
 
Join Date: Nov 2003
Posts: 771
Default Re:running way too rich help

ditch the adjustable regulator, remove your air filter and if you are detonating its cos u aint got enough fuel or your timing is too advanced, try retarding at the dizzy
surfer is offline  
Old 04-21-2004, 12:34 AM
  #9  
3.0 BAR
 
Join Date: Jan 2004
Posts: 2,238
Default Re:running way too rich help

sounds like limp mode to me. code three is map sensor so im thinking your car is seeing the boost. might wanna check that missing link and look into getting a afc with some 450s and ditch that damn fmu. i had one for about 25 mintues that sold it and bought my afc.
mahcivic is offline  
Old 04-21-2004, 02:21 AM
  #10  
Banned
 
Join Date: Aug 2003
Posts: 2,899
Default Re:running way too rich help

Sounds like a combo of limp mode/wastegate/turbo/fmu problem. Im sure ur fmu is working fine, you just have to get used to it, its not effecting anything at idle.. that 60psi is weird. Is this cold start or all idle? Fmus dump alot of fuel and makes pre spool seem like ur car is slow as ----. However if ur not getting any boost then ur map is reading boost or ur wastegate is always open, please double check and make sure the flapper isnt constantly open or that ur spring isnt gone
LSD Motorsports is offline  

Thread Tools
Search this Thread
Quick Reply: running way too rich help


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.