Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > Engine Management
IACV Noise and rough idle after 2.5bar/1000cc precision inj. >

IACV Noise and rough idle after 2.5bar/1000cc precision inj.

Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

IACV Noise and rough idle after 2.5bar/1000cc precision inj.

Old 09-16-2007, 06:19 PM
  #1  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,081
Default IACV Noise and rough idle after 2.5bar/1000cc precision inj.

D16z6 boosted, cromepro, 2.5bar motorolla, 1000cc prescision here's the setup

https://www.homemadeturbo.com/forum/inde ... 56.new#new

Anway, ealier today it ran great on the stock map and dsm450's. I had precision 1000's and a 2.5bar map so I put them both in. I created a new basemap in cromepro and checked it twice, First it was so rich I couldnt keep it running without massaging the pedal, on the 2nd map it was too lean and no matter how much fuel I tried adding it stayed the same. When I let it die I could hear a faint buzzing and discovered the IACV was making the noise, when I unlugged it it went away. I dont know what my problem is I could have wired the map in wrong but I checked the wires with a voltmeter, 1 wire had a strong ground and one was faint, so I used the strong ground as my sensor's ground. Any help would be greatly appreciated 20+psi ripper vids will be posted when I figure this out!!!
ifly87 is offline  
Old 09-16-2007, 08:17 PM
  #2  
3.0 BAR
 
Join Date: Dec 2002
Posts: 3,832
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

What you describe sounds like solid CEL material. Does your CEL operat normally with a key-on and no start? (fuel pump prime, then CEL turns off)

You may need to disable inj. test circuit in the options page.

The MAP wiring is easy to check if your have dlogging working. Key on, connect, and you should see close to 1000 mbar in the dlog window.

Xenocronics site has an easy how-to on wiring 2.5 bar MAPs. Check it against that.


leed is offline  
Old 09-16-2007, 09:59 PM
  #3  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,081
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

Sweet, I didnt even think of using the datalogging to check map operation

I am getting a CEL a few seconds after startup but crome doesnt pick it up and I cant check it via the paper clip trick because as soon as I cycle the ignition it goes away. As for the inj. test circuit I'll give that a try, thanks for the help!


Oh yeah, does anyone have any clue as to what the IACV is all pissed off about? and what does that mean? its making some nasty buzzing noises when its plugged in and the key is on.
ifly87 is offline  
Old 09-18-2007, 09:54 PM
  #4  
3.0 BAR
 
Join Date: Jul 2003
Posts: 6,449
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

Sounds like solid cel to me as well...

What colors are your wires plugged into the IACV?
Chris Harris is offline  
Old 09-18-2007, 11:15 PM
  #5  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,081
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

I wired it up according to this

http://www.phearable.net/tech/wiring/2.5bar.gif

I wired female sockets the the wiring harness side and male sockets to the sensor wires, and my original map plug wires to make it easy to switch back, although I havent tried switching back to the factory sensor yet. I have yet to try and use the datalogging feature to make sure its wired in right, I have been completely swamped with work/school the last few days. Its not my DD but I would still like to get this figured out soon.

I load my bin onto the ostrich and turn the key on, the cel turns off like normal and When I start I have to keep playing with the gas pedal to keep it running, as long as I keep doing that I get NO CEL, but if I let it go, it kills itself and the CEL pops on, crome doesnt pick it up.

Does anyone have ANY clue as to why the IACV is making a buzzing noise with the key on?
ifly87 is offline  
Old 09-19-2007, 12:01 AM
  #6  
3.0 BAR
 
Join Date: Jul 2003
Posts: 6,449
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

I asked about wire colors on the IACV...not the map sensor.
Chris Harris is offline  
Old 09-19-2007, 08:31 AM
  #7  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,081
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

oh sorry, it is the right plug, after this swap I had it swapped with that little black solenoid thingy and kept getting a code14. put the plugs where they are now and it ran perfect for the last three months. I'll check the colors when I get home.
ifly87 is offline  
Old 09-19-2007, 09:59 AM
  #8  
3.0 BAR
 
Join Date: Jul 2003
Posts: 6,449
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

Here is the thing...Injectors, Purge Control, IACV all have the same 12v power source...the dead end connector. The other side of each unit connects directly to the ECU.

If there isnt enough power going through that connector because of a short to ground or something plugged into a different circuit...it could cause what you are describing.
Chris Harris is offline  
Old 09-19-2007, 01:00 PM
  #9  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,081
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

So technically if the map sensor is wired incorrectly, it would cause the iacv to make that noise, its like its trying to pulse but cant sweet, I was kinda wondering if they were on the same circuit. good to know thank you!
ifly87 is offline  
Old 09-19-2007, 06:57 PM
  #10  
3.0 BAR
 
Join Date: Jul 2003
Posts: 6,449
Default Re: IACV Noise and rough idle after 2.5bar/1000cc precision inj.

No...I didnt say anything about them being on the same circuit...read my post again.

Originally Posted by ifly87
So technically if the map sensor is wired incorrectly, it would cause the iacv to make that noise, its like its trying to pulse but cant sweet, I was kinda wondering if they were on the same circuit. good to know thank you!
Chris Harris is offline  

Thread Tools
Search this Thread
Quick Reply: IACV Noise and rough idle after 2.5bar/1000cc precision inj.


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.