Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

Having trouble with my afc setup.. Wayy rich.

Old 05-02-2004, 08:35 PM
  #1  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Having trouble with my afc setup.. Wayy rich.

Well.. heres the setup. y7, obd2, [email protected], secondary o2 sim, MSD BTM, BKR7ES-11's (gapped at .34), dsm 450cc black tops, inline resistors, aem fpr @stock fuel pressure (35ish w/vac attached), Walbro 255lph intank pump, settings -50 . I went to a dyno day to figure out why I wasnt pulling after 4k rpms and see what exactly my a/f was doing. The car feels fine out of boost and idles/drives rich but livable. At full throttle the a/f went below 10 and never came back and my car owned the shop with black smoke. I made like 52hp!!! I recently did a tune up so I dont think thats the problem. I know my wiring is right and the afc sensors are picking up very accurate info. It seemed to get worse after gapping my plugs to .35 but it was always way rich like this. I'm about to go obd1 and uberdata'ed, but I'd really like to know why things are so screwey. No CEL except a rich/lean cel that only occurs at Normal granny driving.

Thanks for the help. I need all I can get. Compression btw is from 187-185ish all the way.
BlinD is offline  
Old 05-02-2004, 09:16 PM
  #2  
3.0 BAR
 
Join Date: Apr 2003
Posts: 2,260
Default Re:Having trouble with my afc setup.. Wayy rich.

Bad injector?
TurboEF9 is offline  
Old 05-02-2004, 09:22 PM
  #3  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Re:Having trouble with my afc setup.. Wayy rich.

Its a possibility. But I kinda doubt it since I knew who they came from. And all of them seem to click and pulse.
BlinD is offline  
Old 05-02-2004, 09:24 PM
  #4  
3.0 BAR
 
Join Date: Nov 2004
Posts: 5,102
Default Re:Having trouble with my afc setup.. Wayy rich.

o2 sensors hooked up? what ecu?
OnYx is offline  
Old 05-02-2004, 09:25 PM
  #5  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Re:Having trouble with my afc setup.. Wayy rich.

yeah o2 is hooked up. I even purchased a new one to check. Didnt change. Stock y7 ecu.
BlinD is offline  
Old 05-02-2004, 09:33 PM
  #6  
3.0 BAR
 
Join Date: Nov 2004
Posts: 5,102
Default Re:Having trouble with my afc setup.. Wayy rich.

you sure you cut te map line and not someting else?
OnYx is offline  
Old 05-02-2004, 09:35 PM
  #7  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Re:Having trouble with my afc setup.. Wayy rich.

Positive sir. Infact the afc reads pressure perfectly.
BlinD is offline  
Old 05-02-2004, 09:36 PM
  #8  
3.0 BAR
 
Join Date: Nov 2004
Posts: 5,102
Default Re:Having trouble with my afc setup.. Wayy rich.

using the resisror pack?;lol
OnYx is offline  
Old 05-02-2004, 09:40 PM
  #9  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Re:Having trouble with my afc setup.. Wayy rich.

inline 10watt 10ohm. I've replaced em like 4 times along with clips to make sure they werent the problem.
BlinD is offline  
Old 05-02-2004, 09:41 PM
  #10  
1.5 BAR
Thread Starter
 
Join Date: Jan 2003
Posts: 1,183
Default Re:Having trouble with my afc setup.. Wayy rich.

I honestly think its gonna be ignition related. Since its only crazy rich at full throttle. And gapping the plugs seemed to make it worse for some reason. (Got new plugs on the way from clubplug)
BlinD is offline  

Thread Tools
Search this Thread
Quick Reply: Having trouble with my afc setup.. Wayy rich.


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.