Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > Engine Management
chipped ECU, options disabled but still have CEL! >

chipped ECU, options disabled but still have CEL!

Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

chipped ECU, options disabled but still have CEL!

Old 07-02-2007, 02:03 PM
  #1  
1.0 BAR
Thread Starter
 
Join Date: Apr 2006
Posts: 503
Default chipped ECU, options disabled but still have CEL!

I've just finished chipping an ECU for a friend. He installed it and found he still had CEL's for ELD (code 20) and Oxygen sensor heater (Code 41).

His previous ECU threw the ELD code, but not the o2 heater code. I disabled the ELD along with injector test, barometric pressure sensor and the speed limiter (JDM P30 code base). But its now throwing this new CEL.

I know I can disable the oxygen sensor heater, but shouldn't have to. Its a 4-wire O2 which seems to have been in working order. The car is N/A at the moment and gas mileage is important to him.

What has gone wrong? I might have forgotten to remove the checksum routine from the rom i burned. The ROM was burned onto a P08 ECU from a JDM EG4 VTi (no crazy JDM fad, just what i found in a junkyard).
DrSeuss is offline  
Old 07-02-2007, 10:56 PM
  #2  
0.0 BAR
 
Join Date: Mar 2004
Posts: 0
Default Re: chipped ECU, options disabled but still have CEL!

Was it a P05? You failed to mention. If it is, that is why. You will need to convert it to a 4 wire O2.
SpankedYA! is offline  
Old 07-03-2007, 08:29 AM
  #3  
1.0 BAR
Thread Starter
 
Join Date: Apr 2006
Posts: 503
Default Re: chipped ECU, options disabled but still have CEL!

The ECU was a P08 from the D15B with crazy three stage vtak. Which has a 4 wire 02 sensor as standard.
DrSeuss is offline  
Old 07-03-2007, 02:08 PM
  #4  
0.0 BAR
 
Join Date: Dec 2002
Posts: 0
Default Re: chipped ECU, options disabled but still have CEL!

Originally Posted by DrSeuss
The ECU was a P08 from the D15B with crazy three stage vtak. Which has a 4 wire 02 sensor as standard.



po8 =normal vtec



and it has a single wire 02 sensor




yes they do if you would like to argue I have gotten i dont know how many jdm d15b right off the boat



all 1 wire o2's




csaddict is correct you need to convert it to 4 wire
Guy-Fast is offline  
Old 07-03-2007, 05:02 PM
  #5  
1.0 BAR
Thread Starter
 
Join Date: Apr 2006
Posts: 503
Default Re: chipped ECU, options disabled but still have CEL!

I've just looked at the bit on PGMFI, I feel like such a dumbass.

Thanks for your help guys, i've got the bits i need at work its just a case of explaining that he needs to send back the ECU now.

DrSeuss is offline  
Old 07-03-2007, 05:05 PM
  #6  
0.0 BAR
 
Join Date: Dec 2002
Posts: 0
Default Re: chipped ECU, options disabled but still have CEL!

Originally Posted by DrSeuss
I've just looked at the bit on PGMFI, I feel like such a dumbass.

Thanks for your help guys, i've got the bits i need at work its just a case of explaining that he needs to send back the ECU now.


Thank you for thanking us that was what hmt was about but alot of people have been very rude here lately



Good luck with ecu
Guy-Fast is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sohcpwr
Hybrid/Tech
2
11-22-2007 01:04 PM
StinkyFeet
Engine Management
7
07-09-2006 08:31 AM
BoosTedZSix
Engine Management
11
04-04-2006 03:49 PM
CivicMike
Engine Management
3
03-31-2005 07:04 PM


Thread Tools
Search this Thread
Quick Reply: chipped ECU, options disabled but still have CEL!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.