Weird electrical problem on 93 Civic... - Page 2 - HomemadeTurbo - DIY Turbo Forum

Go Back  HomemadeTurbo - DIY Turbo Forum > Homemadeturbo > General Discussion
Weird electrical problem on 93 Civic... >

Weird electrical problem on 93 Civic...

General Discussion Off-Topic Discussion and Enlightenment

Weird electrical problem on 93 Civic...

Reply

 
 
 
Old 07-21-2005, 06:28 PM
  #11  
0.0 BAR
 
Join Date: Feb 2005
Posts: 0
Default Re: Weird electrical problem on 93 Civic...

Originally Posted by Dx 101
Originally Posted by Donald125
check your taillight fuse under the dash.
it fuses the taillight light/back up light/cluster light/singal lights all together.

yup thats the ticket. happend to me and i got pulled over for no taillights and then i got searched cuz i just smoked an l and they found my bowl and the biggest roach i had and then they let me go. i htink they smoked my ----
they throw it out because they dont like doing 4-5 hours of work and paperwork for a misdemeanor slap on the wrist fine. atleast thats what ive heard from all the officers i know.
jinxy is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dhn
Hybrid/Tech
9
10-10-2008 10:50 PM
NNBD
Hybrid/Tech
1
01-24-2007 03:55 AM
ixlr8ez
Hybrid/Tech
15
07-15-2006 02:49 PM
WTF
General Discussion
14
05-04-2006 12:07 AM
Darkelvis
General Discussion
6
06-20-2005 12:57 AM


Thread Tools
Search this Thread
Quick Reply: Weird electrical problem on 93 Civic...


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.