Weird electrical problem on 93 Civic... - Page 2 - HomemadeTurbo - DIY Turbo Forum
HomemadeTurbo - DIY Turbo Forum

General Discussion Off-Topic Discussion and Enlightenment

LinkBack Thread Tools Search this Thread
Old 07-21-2005, 05:28 PM   #11
0.0 BAR
Join Date: Feb 2005
Posts: 0
Default Re: Weird electrical problem on 93 Civic...

Originally Posted by Dx 101
Originally Posted by Donald125
check your taillight fuse under the dash.
it fuses the taillight light/back up light/cluster light/singal lights all together.

yup thats the ticket. happend to me and i got pulled over for no taillights and then i got searched cuz i just smoked an l and they found my bowl and the biggest roach i had and then they let me go. i htink they smoked my ----
they throw it out because they dont like doing 4-5 hours of work and paperwork for a misdemeanor slap on the wrist fine. atleast thats what ive heard from all the officers i know.
jinxy is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
weird electrical problem..need help fast dhn Hybrid/Tech 9 10-10-2008 09:50 PM
weird case of blue smoke.....very weird. NNBD Hybrid/Tech 1 01-24-2007 02:55 AM
Electrical problem please help! ixlr8ez Hybrid/Tech 15 07-15-2006 01:49 PM
crazy electrical problem WTF General Discussion 14 05-03-2006 11:07 PM
Electrical system problem. Darkelvis General Discussion 6 06-19-2005 11:57 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:35 AM.

Copyright 2017
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to and affiliated sites.