General Discussion Off-Topic Discussion and Enlightenment

Honda B16a1

Old 11-16-2012, 06:08 AM
  #1  
0.0 BAR
Thread Starter
 
Join Date: Apr 2009
Posts: 6
Default Honda B16a1

I have a 1990 UKDM CRX fitted with a B16A2 EK4 VTI engine running of the CRX OBD0 management.

The engine ran fine but started loosing spark so i tried a distributor. Got spark back but no fuel so built afew dizzy's until i got fuel and spark but now it's drowning the plugs with fuel.

I've checked timing from top to bottom and all is spot on. Tried another ecu, tried bypassing the main relay, checked plug lead order and tested all the new sensors in the dizzy.

What else can it be?
BONNARSKI is offline  
Old 11-24-2012, 04:53 AM
  #2  
0.0 BAR
Thread Starter
 
Join Date: Apr 2009
Posts: 6
Default

Update so far -

Found out the ecu i was given is bad, plug it in and the main relay clicks but no fuel pump action. Plug mines back in and all works as it should.

Just recently found out that there is a difference between the crank wheels in the OBD0 and OBD1/2 dizzy's. Might seem and obvious mistake to some but i have never came across any info on this in over a year of looking about Honda distributors online.

So built another with a good ICM and my ecu put up CEL 8, TDC sensor, so replaced it but still no go.

WTF?
BONNARSKI is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WhiteGuy
Hybrid/Tech
3
03-15-2003 12:24 AM
redzcstandardhatch
Hybrid/Tech
8
02-24-2003 10:19 AM
HiKneeKen
Hybrid/Tech
4
02-18-2003 07:45 PM
CRXzc903
General Discussion
2
01-05-2003 08:58 PM
sleepin Crx
Forced Induction
11
12-28-2002 06:16 PM


Thread Tools
Search this Thread
Quick Reply: Honda B16a1


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.