Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

Rough idle B16a

Old 04-19-2009, 10:12 AM
  #1  
1.0 BAR
Thread Starter
 
civic2437's Avatar
 
Join Date: Apr 2006
Location: Bristol CT
Posts: 204
Angry Rough idle B16a

Did my b16a swap on my 89 ef and i'm getting a ridiculous rough idle, gas pedal down to floor and car seems to not rev up past maybe 2500k,as sson as i back off the pedal car is just sputtering and dies, on that note i'm getting code 7,8,and 21,tried new distributor but no go!! Any ideas for some solutions
civic2437 is offline  
Old 04-19-2009, 10:20 AM
  #2  
0.5 BAR
 
Join Date: Apr 2009
Posts: 53
Default

ok 7 is your tps sensor try swapping the 2 outer wires of your tps

8 is your tdc if you swapped a new dizzy did you reset the pcm?

and 21 is vtec solenoid run vtec wiring and youll be fine

your not going past 2500 is most likely your tps wires arent wires correctly so swap them around

hope this helps
izzyef8 is offline  
Old 04-19-2009, 10:28 AM
  #3  
1.0 BAR
Thread Starter
 
civic2437's Avatar
 
Join Date: Apr 2006
Location: Bristol CT
Posts: 204
Default

I did the swap on the tps,and also what did you mean by reset the pcm? the ecu??when i put the new dist,it actually wouldn't even start put the old one back on and the thing starts but just sounds horrible it putts really low even with the throttle all the way,vtec is wired up!
civic2437 is offline  
Old 04-19-2009, 10:32 AM
  #4  
0.5 BAR
 
Join Date: Apr 2009
Posts: 53
Default

pull your radio fuse for about 10 sec so the ecu can erase the codes and then start it up

which harness are you using
izzyef8 is offline  
Old 04-19-2009, 10:42 AM
  #5  
0.5 BAR
 
Join Date: Apr 2009
Posts: 53
Default

the other day i finished a b20 swap on a del sol same kinda problem took me all day to figure it out. i had map tps and vtec code not the tdc code and it ended up being my injectors that were bad. if you have your single cam injectors and you know there good id give it a shot and swap them
izzyef8 is offline  
Old 04-19-2009, 11:36 AM
  #6  
1.0 BAR
Thread Starter
 
civic2437's Avatar
 
Join Date: Apr 2006
Location: Bristol CT
Posts: 204
Default

i'm using the dx harness but with the si conversion,i do have the single cam injectors still,would they fit the b16 fuel rail
civic2437 is offline  
Old 04-19-2009, 11:44 AM
  #7  
0.5 BAR
 
Join Date: Apr 2009
Posts: 53
Default

yeahthey should be interchangable
izzyef8 is offline  
Old 04-19-2009, 11:55 AM
  #8  
1.0 BAR
Thread Starter
 
civic2437's Avatar
 
Join Date: Apr 2006
Location: Bristol CT
Posts: 204
Default

ok ill give that a try,it might be that,but what could the tdc code be from?
civic2437 is offline  
Old 04-19-2009, 12:19 PM
  #9  
0.5 BAR
 
Join Date: Apr 2009
Posts: 53
Default

you obd0 or obd1

if your obd1 you crank sensors actually on the crank as where obd0 its in the dizzy.

when i did my single cam vtec for one of my cars and obd0 to obd1 i had the crank sensor code always but car started up fineand everything just that my obd0 block didnt have the crank sensor like newer ones do on the crank. if you look at your motor where your harmonic balancer is behing it should be a plug that comes out if its there you have a newer motor so dont really stress on it if your obd0 if your obd1 you need to plug that in so the mil goes away
izzyef8 is offline  
Old 04-19-2009, 05:17 PM
  #10  
1.0 BAR
Thread Starter
 
civic2437's Avatar
 
Join Date: Apr 2006
Location: Bristol CT
Posts: 204
Default

i'm running obd0,but i cant find my other obd0 injector clips!
civic2437 is offline  

Thread Tools
Search this Thread
Quick Reply: Rough idle B16a


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.