Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

LOCK THIS BITCH AND DELETE IT!!!!

Old 01-31-2008, 11:13 PM
  #1  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,299
Default LOCK THIS BITCH AND DELETE IT!!!!

well i dont know what the deal is. ive replaced the plugs with the factory ngk's, same with the wires. ive cleaned up the dizzy and cap for garbage. i believe my timing is good, but i dont have a timing belt cover on the engine to check for proper timing, but when engine was installed, cam/crank were tdc and car started right up first time being cranked over. ive also replaced the fuel filter and ran some cleaner in the tank for the injectors and tank itself. the o2 was brand new as well, but i think it may be going bad or i have a bad connection to the ecu, because my narrow/wideband reads for a while sometimes then stops.

im beginning to think this motor has injectors going bad, or i need a custom tune on it do to the modifications to it. ill list what it has below.

d15b2 block stock bottom end with d16y7 crank pulley
d16y7 head, cam gear
d16a6 dizzy from mpfi swap first time around with the car
4 speed std trans with exedy stage 1 organic clutch
stock exhaust manifold from a6
2 inch exhaust free flowing

i can baby the ---- out of it and still only muster 200 mile to a tank. i think that is very low for a honda even with the occasional drop a gear and pass on the way to school. i dont know wtf is going on. it beginning to irritate me bad.
78NOVA is offline  
Old 01-31-2008, 11:17 PM
  #2  
3.0 BAR
 
Join Date: May 2005
Posts: 1,811
Default Re: still bad gas millage

my stock one get's 400m/tank so yeah you're getting screwd by the fuel injectors.

even with the head and mpfi swap you oughta be getting 350 a tank.
Toysrme is offline  
Old 01-31-2008, 11:26 PM
  #3  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,299
Default Re: still bad gas millage

Originally Posted by Toysrme
my stock one get's 400m/tank so yeah you're getting screwd by the fuel injectors.

even with the head and mpfi swap you oughta be getting 350 a tank.
i say the same thing, ill be happy to even get 320 out of the bitch. oh, your avatar, is nuts.....
78NOVA is offline  
Old 01-31-2008, 11:37 PM
  #4  
3.0 BAR
 
Join Date: Jan 2003
Posts: 1,798
Default Re: still bad gas millage

would a leaky injector cause this?
Sinner is offline  
Old 01-31-2008, 11:39 PM
  #5  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,299
Default Re: still bad gas millage

Originally Posted by Sinner
would a leaky injector cause this?
possibly, they or one or so of them is getting stuck and staying open to long? i dont have another car to drive so i can check them or any other injector that re good to put in its place. if i had a good set of stock a6 ones id put them on to find out if thats the problem, but all i have is a set of dsm 450's for when i boost.
78NOVA is offline  
Old 01-31-2008, 11:59 PM
  #6  
1.5 BAR
 
Join Date: Dec 2006
Posts: 1,049
Default Re: still bad gas millage

you have wideband? then you should know if it's running rich or not..

if you don't then smell the exhaust while it's warmed up at idle, have a friend give it some gas.. light black smoke would indicate you're running rich also, which I assume you already knew.

are you running the right ecu? I had a p28 ecu on my b16 swap for a few weeks and it ran really rich.
marcj is offline  
Old 02-01-2008, 12:03 AM
  #7  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,299
Default Re: still bad gas millage

Originally Posted by marcj
you have wideband? then you should know if it's running rich or not..

if you don't then smell the exhaust while it's warmed up at idle, have a friend give it some gas.. light black smoke would indicate you're running rich also, which I assume you already knew.

are you running the right ecu? I had a p28 ecu on my b16 swap for a few weeks and it ran really rich.
no i have no wideband, i just have a af guage on the narrowband side. im still working on getting a wideband setup. and no i actually dont smoke at all, there is none to be seen either. doesnt smell like its running rich either. and i have a pm6 from an 88 rex or a pr5 from a 91 teg that i can use. currently i have the pr5 on it and its runs smoother. the pm6 is good as well, but i dont feel as though it has much power like the pr5.
78NOVA is offline  
Old 02-01-2008, 12:04 AM
  #8  
3.0 BAR
 
Join Date: Jan 2003
Posts: 1,798
Default Re: still bad gas millage

is your fuel return actually returning your fuel ? I'm guessing you would smell it.
Sinner is offline  
Old 02-01-2008, 12:14 AM
  #9  
3.0 BAR
Thread Starter
 
Join Date: Dec 2005
Posts: 2,299
Default Re: still bad gas millage

Originally Posted by Sinner
is your fuel return actually returning your fuel ? I'm guessing you would smell it.
i believe it is, i do not smell gas on the outside of my car when its running or not running. there are no leaks anywhere, except for my cam gear leak i need to fix.
78NOVA is offline  
Old 02-01-2008, 12:22 AM
  #10  
1.5 BAR
 
Join Date: Dec 2006
Posts: 1,049
Default Re: still bad gas millage

you need to run the ecu for the d15 since that matches your displacement
marcj is offline  

Thread Tools
Search this Thread
Quick Reply: LOCK THIS BITCH AND DELETE IT!!!!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.