Engine Management eCtune , Crome , AFC , FMU , Zdyne , Hondata , EMS , TE , Uberdata Anything to control your fuel, spark needs!

bogging at 5k

Old 04-18-2005, 05:59 PM
  #1  
0.0 BAR
Thread Starter
 
Join Date: Sep 2004
Posts: 48
Default bogging at 5k

I just installed the turbo on the y7 and it pulls good in first, but in second and third, probably fourth too, the revs stop climbing at about 4.5-5k. The tps was messed up so I adjusted that so it reads .5v closed throttle, 4.5-4.6v WOT. from 1-3k the afc reads 100% throttle, but at about 4.5k it starts to read 98-99%, when the revs stop climbing. I've adjusted the tps all the way I can't get anymore rotation out of it. We did ghetto rig the throttle rotor to work with the y8 IM so that's a possiblitiy. Could It be fuel, it's set at -36% at 4-5.5k with 450's. Thanks for any help in advance, and if anyone's got an extra throttle rotor, I'm intrested.


Thanks,
Mark
hatch96 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MegaX
Engine Management
3
11-18-2003 08:39 PM
ZChatch
Forced Induction
28
07-15-2003 03:02 AM
kine462
Engine Management
5
07-08-2003 12:54 AM
coppercivic
Forced Induction
10
05-16-2003 10:28 AM
Sinner
Forced Induction
5
04-16-2003 08:13 PM


Thread Tools
Search this Thread
Quick Reply: bogging at 5k


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.